Parker Software Ltd Homepage
Forum Home Forum Home > ThinkAutomation Business Process Automation > Email2DB Version 3
  New Posts New Posts RSS Feed - Can't Send Outgoing Email
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Can't Send Outgoing Email

 Post Reply Post Reply
Author
Message
Dan Schubel View Drop Down
New User
New User


Joined: 27 Sep 2017
Location: USA
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dan Schubel Quote  Post ReplyReply Direct Link To This Post Topic: Can't Send Outgoing Email
    Posted: 27 Sep 2017 at 8:25am
I am trying to create a trigger action to send an email. I  have checked "Send Outbound Via Smart Host" and entered the SMTP details. Clicking Send Test from here works and I am able to send a test email to myself.
However, when I click "Send Test" from the Trigger Action editing window, I get a pop-up message that says "Email Added to Outbox" but I never get an email.
The SMTP Service Log and Outbound Email Log are both empty.
I have created only one account that recieves emails and I have checked "outbox" for this account
Back to Top
parkersoft-jim View Drop Down
Admin Group
Admin Group
Avatar

Joined: 11 Nov 2016
Location: Terra
Points: 76
Post Options Post Options   Thanks (0) Thanks(0)   Quote parkersoft-jim Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2017 at 9:48am
Check the logs found under Service Status -> Mail Server Status -> Mail Server log to see if it reached the smarthost or if the smarthost rejected it.

When smarthosting your Thinikautomation computer will try to connectdirectly via SMTP port 25 to your chosen smarthost.
Back to Top
Dan Schubel View Drop Down
New User
New User


Joined: 27 Sep 2017
Location: USA
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dan Schubel Quote  Post ReplyReply Direct Link To This Post Posted: 28 Sep 2017 at 8:30am
This is what I see in SMTP service log:
9/27/2017 12:10:43 PM Mail Server Started 3.1.0483
9/27/2017 12:10:44 PM Loaded Metadata 4 Whitelist Entries, 0 Blacklist Entries
9/27/2017 12:10:44 PM SMTP Server Listening On diogenes.gamry.com:8812
9/27/2017 12:10:44 PM Startup Complete
9/27/2017 12:10:50 PM smtp.office365.com Outgoing Message For Jcostello@Gamry.com Sent
9/27/2017 12:13:01 PM smtp.office365.com Outgoing Message For Jcostello@Gamry.com Sent
9/27/2017 12:18:50 PM SMTP Server Stopped
9/27/2017 12:18:50 PM SMTP Server Listening On diogenes.gamry.com:8812
9/27/2017 12:18:50 PM Loaded Metadata 4 Whitelist Entries, 0 Blacklist Entries
 12:04:00 AM Mail Server Server Log For: Thursday 28 Sep 2017
9/28/2017 12:04:00 AM Loaded Metadata 4 Whitelist Entries, 0 Blacklist Entries
9/28/2017 9:00:14 AM Queue Refresh Enabled
9/28/2017 9:00:29 AM Queue Refresh Enabled
9/28/2017 9:02:04 AM Queue Refresh Enabled
9/28/2017 9:02:09 AM Queue Refresh Enabled
9/28/2017 9:02:29 AM Queue Refresh Enabled
9/28/2017 9:02:33 AM Queue Refresh Enabled
9/28/2017 9:02:41 AM Queue Refresh Enabled
9/28/2017 9:02:45 AM Queue Refresh Enabled
9/28/2017 9:07:28 AM Queue Refresh Enabled
9/28/2017 9:08:30 AM Queue Refresh Enabled


As a side note: The emails sent to Jcostello@Gamry.com I believe are the result of a error with a Database Command trigger action (Has been fixed). I would like those type of emails sent to me. I thought I made the change to the email address but I must be missing something????
Back to Top
parkersoft-jim View Drop Down
Admin Group
Admin Group
Avatar

Joined: 11 Nov 2016
Location: Terra
Points: 76
Post Options Post Options   Thanks (0) Thanks(0)   Quote parkersoft-jim Quote  Post ReplyReply Direct Link To This Post Posted: 28 Sep 2017 at 9:17am
The logs indicate your smarthost accepted the email.

9/27/2017 12:10:50 PM smtp.office365.com Outgoing Message For Jcostello@Gamry.com Sent
9/27/2017 12:13:01 PM smtp.office365.com Outgoing Message For Jcostello@Gamry.com Sent

You'd need to check the logs on smtp.office365.com to find out what the smarthost did with that email though.

The destination email address is set in the 'To' field in the 'Send An Email' trigger action template. Obviously you'd have to change this in each individual Send An Email trigger action as they're each independant of each other.

http://www.thinkautomation.com/help/action_message.htm
Back to Top
Dan Schubel View Drop Down
New User
New User


Joined: 27 Sep 2017
Location: USA
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dan Schubel Quote  Post ReplyReply Direct Link To This Post Posted: 28 Sep 2017 at 10:34am
Where is the Outbox the message is added to?
9/28/2017 11:32:37 AM New Admin Message For Account: WebOrders, Trigger: ServiceRequest, Dated: 9/28/2017 11:32:37 AM, From: postmaster, (868 Bytes)
9/28/2017 11:32:37 AM Subject: Service Request Receieved
9/28/2017 11:32:37 AM Variable NewRMA Set To
9/28/2017 11:32:37 AM SQL executed against database
9/28/2017 11:32:37 AM Executed Database Command
9/28/2017 11:32:37 AM Variable NewRMA Set To 2017-005442
9/28/2017 11:32:37 AM Message For dschubel@gamry.com Added To Outbox
9/28/2017 11:32:37 AM Popup Message Sent

Back to Top
parkersoft-jim View Drop Down
Admin Group
Admin Group
Avatar

Joined: 11 Nov 2016
Location: Terra
Points: 76
Post Options Post Options   Thanks (0) Thanks(0)   Quote parkersoft-jim Quote  Post ReplyReply Direct Link To This Post Posted: 28 Sep 2017 at 12:41pm
I assume that is from the trigger process log.

It's not an outbox per se, as in a mailbox for storing a message.

Think of it as being passed into the 'outbound' mail queue of the MTA (mail transfer agent) components of ThinkAutomation.

As above, the best way to check if the e-mail was actually relayed successfully (or accepted by the next-hop MX records if you weren't using a smarthost and sending directly) is to check the Service Status -> Mail Server Status -> Mail Server log
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.05
Copyright ©2001-2016 Web Wiz Ltd.

This page was generated in 0.063 seconds.