Print Page | Close Window

chat not working in Chrome and Firefox

Printed From: Parker Software Ltd
Category: WhosOn Live Chat
Forum Name: FAQ's
Forum Description: WhosOn FAQ's
URL: http://www.parkersoftware.com/forum/forum_posts.asp?TID=9375
Printed Date: 22 Feb 2020 at 3:13am
Software Version: Web Wiz Forums 11.05 - http://www.webwizforums.com


Topic: chat not working in Chrome and Firefox
Posted By: damian
Subject: chat not working in Chrome and Firefox
Date Posted: 13 Sep 2018 at 4:05am
Whos On has suddenly stopped working in Chrome and Firefox, but still works in IE11 and Edge.

When I look at the console in Chrome, I see the following error:
GET https://www.example.com/chat/include.js?domain=www.example.com" rel="nofollow - https://www.example.com/chat/include.js?domain=www.example.com net::ERR_CONTENT_DECODING_FAILED 200 (OK)

Firefox gives me this error:
Loading failed for the <script> with source " https://www.example.com/chat/include.js?domain=www.example.com" rel="nofollow - https://www.example.com/chat/include.js?domain=www.example.com"

My embed code is as follows:
<li style="display:none" id="whoson_chat_wrapper">
<!-- Embedded WhosOn: Insert the script below at the point on your page where you want the Click To Chat link to appear -->
<script type="text/javascript" src=" https://www.example.com/chat/include.js?domain=www.example.com" rel="nofollow - https://www.example.com/chat/include.js?domain=www.example.com" ></script>
<script>if(typeof sWOTrackPage=="function")sWOTrackPage();</script>
</li>

Both browsers also give me this error:
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/" rel="nofollow - http://xhr.spec.whatwg.org/

Could this be due to a recent update of Chrome and Firefox which is now blocking the synchronous embeded script?

If this is the case, is there a known fix?

Thanks.
Damian



Replies:
Posted By: Biker-Jim
Date Posted: 13 Sep 2018 at 7:48am
I assume you are not actually using example.com as the chat server hostname.

Try taking the tracking code out of the <li> (list) tags as from your excerpt you appear to have it embedded in them. As it is javascript you don't need to put it inside list tags.

To advise better, I will need the URL of one of the webpages where you tracking code is present.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.05 - http://www.webwizforums.com
Copyright ©2001-2016 Web Wiz Ltd. - https://www.webwiz.co.uk